Seite 1 von 1

Ajax-Fehlermeldung wegen Board Greetings to Xmas and New Year

Verfasst: Fr 19. Apr 2019, 10:58
von Volker
Hi allerseits

Bei meinem Kumpel läuft die neueste Version PHPBB 3.2.5 und wenn "Board Greetings to Xmas and New Year" aktiviert ist, erscheint eine Ajax-Fehlermeldung (siehe Bild). Da das Teil ja schon älter und eigentlich für phpBB 3.1 ist, wollte ich fragen ob man das an die neue PHPBB-Version anpassen kann oder ob ich da nur irgendwas an Code ergänzen muss.

Danke und Gruß Volker
Ajax.jpg
Ajax.jpg (22.92 KiB) 1893 mal betrachtet

Re: Ajax-Fehlermeldung wegen Board Greetings to Xmas and New Year

Verfasst: Fr 19. Apr 2019, 11:11
von Kirk
Hallo
Ich kann diesen Fehler nicht nachvollziehen, welche PHP Version läuft bei deinem Kumpel und hat er irgendwas geändert?
Hier ist diese EXT unter PHP 7.2.5 auch aktiv.

Re: Ajax-Fehlermeldung wegen Board Greetings to Xmas and New Year

Verfasst: Fr 19. Apr 2019, 11:45
von Volker
Hallo kirk

PHP-Version ist 5.6.40 und geändert hat er nix und ich auch nicht weil ich mich meist um die technischen Sachen kümmere. Wenn ich auf eine höhere PHP-Version wechseln will, geht auf einmal das ganze Board nicht mehr. Es erscheinenen dann unterschiedliche Fehlermeldungen wie z.B. SQL-eror oder auch eine bezüglich board_online_time (siehe code)
Fatal error: Uncaught Error: Call to undefined function kirk\board_online_time\event\split() in /hp/co/aa/ax/www/Pilzforum/ext/kirk/board_online_time/event/listener.php:91 Stack trace: #0 /hp/co/aa/ax/www/Pilzforum/vendor/symfony/event-dispatcher/EventDispatcher.php(184): kirk\board_online_time\event\listener->display_board_online_time(Object(phpbb\event\data), 'core.page_foote...', Object(phpbb\event\dispatcher)) #1 /hp/co/aa/ax/www/Pilzforum/vendor/symfony/event-dispatcher/EventDispatcher.php(46): Symfony\Component\EventDispatcher\EventDispatcher->doDispatch(Array, 'core.page_foote...', Object(phpbb\event\data)) #2 /hp/co/aa/ax/www/Pilzforum/phpbb/event/dispatcher.php(62): Symfony\Component\EventDispatcher\EventDispatcher->dispatch('core.page_foote...', Object(phpbb\event\data)) #3 /hp/co/aa/ax/www/Pilzforum/phpbb/event/dispatcher.php(46): phpbb\event\dispatcher->dispatch('core.page_foote...', Object(phpbb\event\data)) #4 /hp/co/aa/ax/www/Pilzforum/includes/functions.php(4673): phpbb\event\dispatcher->trigger_event('cor in /hp/co/aa/ax/www/Pilzforum/ext/kirk/board_online_time/event/listener.php on line 91

Re: Ajax-Fehlermeldung wegen Board Greetings to Xmas and New Year

Verfasst: Fr 19. Apr 2019, 12:02
von Kirk
Wegen dieser Fehlermeldung, einfach auf neuste Version updaten.
Was die Ajax-Fehlermeldung angeht, ich kann es nicht nachvollziehen, was habt ihr sonst noch für Extensionen inst.?
Kontrolliert mal alle eure Extensionen ob diese aktuell sind.

Re: Ajax-Fehlermeldung wegen Board Greetings to Xmas and New Year

Verfasst: So 21. Apr 2019, 18:16
von Volker
Hi Kirk

Sorry für die späte Antwort, aber lieber spät als nie. Also ich habe jetzt mal auf die php-Version 7.0 aktualisiert und alle Extensionen auf Aktualität geprüft und entsprechend reagiert. Die Extension "Board Greetings to Xmas and New Year" bringt immer noch den Ajax-Fehler.

Gruß Volker

Re: Ajax-Fehlermeldung wegen Board Greetings to Xmas and New Year

Verfasst: So 21. Apr 2019, 19:54
von Kirk
Aktiviere mal den Debug-Modus, dazu muust du die root/config.php ändern. Sucht dort nach // @define('DEBUG', true); und änder dies so um @define('DEBUG', true);
Sollte es ein Problem geben, erscheint oben eine Fehlermeldung. Deaktiviere alle Extensionen bis auf die und schau ob diese Meldung immer noch erscheint.
Es wäre hilreich wenn du alle Extension (inkl. Downloadlink) die installiert sind hier auflistest.

Re: Ajax-Fehlermeldung wegen Board Greetings to Xmas and New Year

Verfasst: Mo 22. Apr 2019, 06:57
von Volker
Moin Kirk

Ich habe es jetzt ganz anders gemacht. Ich habe die Extension deaktiviert, die Arbeitsdaten gelöscht und den Ordner der Extension per FTP entfernt. Dann wieder neu hochgeladen und aktiviert und Bingo, der Ajax-Fehler ist weg und es kommt im Debug-Modus auch keine Fehlermeldung.

Gruß Volker