Problem beim aktivieren von Erweiterungen (AJAX-Fehler)

Eingeschränkter Support!
Forumsregeln
Bei Fragen zu einer bestimmten Extension sind Extension-Name und die Downloadquelle (Link) der Extension erforderlich.
Benutzeravatar
Wolken
Offline
Beiträge: 36
Registriert: Sa 18. Apr 2015, 03:20
Kontaktdaten:
Jan 2020 12 23:42

Problem beim aktivieren von Erweiterungen (AJAX-Fehler)

Beitrag von Wolken


Ich habe das Thema zwar schon bei phpBB.de geschrieben. Da es dort vielleicht übersehen wird, hoffe ich hier auf Hilfe.

Zwischenzeitlich habe ich mein aktives Forum auf phpBB 3.3.0 aktualisiert.

Nachdem ich etliche Erweiterungen aktiviert habe, die wie es aussieht auch funktionieren kann ich plötzlich keine weitere Erweiterung mehr aktivieren. Es kommt folgende Fehlermeldung:

AJAX-Fehler
Bei deiner Anfrage ist etwas falsch gelaufen und der Server hat eine ungültige Antwort zurückgegeben.


Cache per FTP geleert - Fehler bleibt.

php Version: 7.1.32 - Datenbank-Server: MySQL(i) 10.2.27-MariaDB

Wenn ich eine bereits aktivierte Erweiterung deaktivieren will kommt zuerst die Frage ob ich das wirklich will, wenn ich dann mit JA bestätige kommt die gleiche Fehlermeldung wie oben genannt. Mache ich das zweimal nacheinander ist die Erweiterung trotz vorheriger Fehlermeldung deaktiviert.

Aktivieren geht allerdings nicht. Blöder Fehler.

Benutzeravatar
Kirk
Administrator
Offline
Beiträge: 1124
Registriert: Di 15. Apr 2014, 10:54
Wohnort: Erde
Kontaktdaten:
Jan 2020 13 06:42

Re: Problem beim aktivieren von Erweiterungen (AJAX-Fehler)

Beitrag von Kirk


Hallo
Du müsstest eine EXT nach der anderen deaktivieren und nach der Deaktivierung einer EXT prüfen ob der Fehler noch da ist.
Gruß Udo

Benutzeravatar
Wolken
Offline
Beiträge: 36
Registriert: Sa 18. Apr 2015, 03:20
Kontaktdaten:
Jan 2020 13 06:54

Re: Problem beim aktivieren von Erweiterungen (AJAX-Fehler)

Beitrag von Wolken


Hallo Kirk, du hattest zuerst bei phpBB.de geantwortet. Ich habe alle Erweiterungen deaktiviert. Dabei folgenden Fehlermeldung bekommen und kann jetzt keine Erweiterung mehr aktivieren.

Code: Alles auswählen

[phpBB Debug] PHP Notice: in file [ROOT]/phpbb/db/migrator.php on line 157: unserialize(): Error at offset 0 of 11 bytes
��Yms�:��� �w�I���Zh�0-�w.�;�,�NG�ObQ�!�I��?ُ�3���G���%�]萙�ґ|��I��|���OH$�x�� ��Xr��4�xV��#IIQ.@zV!���"GR�6�-�Գ��۷gIN%�c�H��R|���o�4Ϛ2�����3��a��ug���IFc[4�o�H&c��'(.K��!��Ø�$�0�,�u� T\����t"K�IX� �?����<��س��� "�T���. ����͖p)�2I d� �v���a��]��N��?mO)'o�$?���G:Ϙ�����B��H�%�j���8M7M�]qeRX&Aj��z<�" B:��=�A�.䗔�U�O�<.Im�Ν��3*OdF����=.�@EM[%��F����h���Hv6oV�7�e��IWO\�<�qL���/�M�P}��#ϩ��q�e��؈�6�-���Uz;, ����y��P��}�����,(�S'��t��Twa�]�y$$���`�k��I��Y8Mh�>��n����4���N�|ϝl��:j��o*�C�C��_�E���6~v X�B�I6F/q�H/N�R��z��~���$(\*�y�J^�;�h�Y#�JR̄���)߬E^K����ObP̓�Q�/n���ç,<��aͼ\���,x���5���RJO�1�Wt�U�vX�����t�[�RoCd�ĐNd�ݻwkY��S~�(sQ�B�n�XW���݅Yg&�LPD�P'���"�̸���G?�S�PB<x��c9/p%��I���gy���&��F���࿎�'�� Rv�N#:r{Ka �lF4�����#`�H�`�����9��v�ʹ'�!�^��U�t��즩V�&��)�zs���Y�X�t�(�_ѭ����AޭX���������s���P�fo��� C6�e�ŋ�)�A�=[1��a�������U.�������|4���&��$'��G��!菃A�� w�w��������{t��޲���|U�ć.�u�r�4�-�.�+��nn4�6��NXH���}]$�(�h\{a袛�Wܥ�l�U�%�����E���ո N��o��lc�������Fט}o�ۥ_oK�Ckt����-�����pR �=�E�ߞ��m%��,���o%�87�o��@%W�����=�g�����|k"w���\HHn�H<�<�3���+�;t t,@g /����<���%w ��`���#�<2!`�!`3�C��^~�������Ǻb��t=�E��4�rmt�����$+���x�k��j��l�����.��^`���/M��q���b|�ߗ��(�ɧi��վ�������d��{C��l v����=Lpu��>âV.�%�Z��F3\ �*�1���)St �>�/����*0U�5�����f,�mm7u#%��.�7S���Z�fq�p��E�8Q�K�)u�P�o�G�ʹ H$S������ �������vH�,�޲��Zb�E��9ZSİڰC3 �6&K'���s�s�'���Iu�W�N{�YE9�ip!�Rk���p3�~8�jt�х�1\��V�$묨Jr=t��V�>$� !��R�֢��="�۪���/3�Dt �ܑ��kYC���=\�m���t"�]�6�Y�)!3���8�du���d��������l�h�<��Z�뺳�L���;A�����|s��<����$��@��=�'�_X���F� )0lj9�|�IN‚ї$�P Ʀ�]�"�X�T�}��Y'����vI���z�����K��-��W�^���=9zA�C��9�M�'wɖs��� 0�ƀ���I �r"f`��Nx��~��\}$�p�d\UB�<��@�OԙX9����X��*}��UY/g����>@'(���fx�Q��n�L=⌆�s�Tf�*+�E/�s��S�i�4h��r�g5�%�b`�*\fsx�L���Gi��ri����<�3�v�e�#�7�uj�q��a~e�g-�>s�1�cƓ���:�j�ݔ%\� L�y�4?n-7�Us{˹���7.uO��׼ � 〯���Uc���`�q�� x|�Eh��[=�?��P��|������:�
Es kommt der gleiche Fehler wie im ersten Beitrag.

Jetzt sehe ich alt aus. Was tun. Gleich 1 Uhr vor Ort.

Benutzeravatar
Wolken
Offline
Beiträge: 36
Registriert: Sa 18. Apr 2015, 03:20
Kontaktdaten:
Jan 2020 22 14:50

Re: Problem beim aktivieren von Erweiterungen (AJAX-Fehler)

Beitrag von Wolken


Ich wollte mich noch einmal zum Thema melden. Da ich auf phpBB.de leider nicht die erwartete Hilfestellung bekommen habe, blieb mir nichts anderes übrig als einen Dienstleister mit der Fehlerbehebung zu beauftragen. Als ich dann die Rechnung bekam bin ich vom Hocker gefallen. Zumindest läuft jetzt alles wieder.
An den Erweiterungen habe ich seitdem nichts mehr geändert, da ich irgendwie das ungute Gefühl habe, dass der Fehler wieder auftreten könnte.

Benutzeravatar
Kirk
Administrator
Offline
Beiträge: 1124
Registriert: Di 15. Apr 2014, 10:54
Wohnort: Erde
Kontaktdaten:
Jan 2020 22 15:54

Re: Problem beim aktivieren von Erweiterungen (AJAX-Fehler)

Beitrag von Kirk


Es wäre interessant zu erfahren an was es gelegen hat.
Gruß Udo

Benutzeravatar
Wolken
Offline
Beiträge: 36
Registriert: Sa 18. Apr 2015, 03:20
Kontaktdaten:
Jan 2020 22 17:52

Re: Problem beim aktivieren von Erweiterungen (AJAX-Fehler)

Beitrag von Wolken


Es soll an dem von mir eingefügtem Snippet (Debug Modus in phpBB 3.3 aktivieren) gelegen haben. Möglich dass mir dabei ein Fehler unterlaufen ist, glaube ich fast nicht, schließe es auch nicht aus. In zwei anderen Foren und in meinem Testforum läuft es so wie auf phpbb.de beschrieben und bereitet keine Probleme.

Wie gesagt es kann sein, dass ich mich bei mir vertippt habe.

Nach der Reparatur sieht es bei mir jetzt anders aus. In der Datei config.yml im Ordner /config/default/config.yml steht:

Code: Alles auswählen

# phpBB's config file (This line is needed because of the packager)
parameters:
    debug.load_time: true
    debug.sql_explain: true
    debug.memory: true
    debug.exceptions: true
Die anderen Dateien im Ordner config sind unverändert.

Könnte das etwas mit dem im ersten Beitrag beschriebenen Fehler zu tun haben?

Benutzeravatar
Kirk
Administrator
Offline
Beiträge: 1124
Registriert: Di 15. Apr 2014, 10:54
Wohnort: Erde
Kontaktdaten:
Jan 2020 22 18:13

Re: Problem beim aktivieren von Erweiterungen (AJAX-Fehler)

Beitrag von Kirk


Ich hab es wie Luke wie hier geschrieben eingefügt (auch hier im Board) hätte bisher keine Probleme damit.
Gruß Udo

Benutzeravatar
Wolken
Offline
Beiträge: 36
Registriert: Sa 18. Apr 2015, 03:20
Kontaktdaten:
Jan 2020 22 18:41

Re: Problem beim aktivieren von Erweiterungen (AJAX-Fehler)

Beitrag von Wolken


Könnte, wenn ich in dem Ordner config mich vertippt haben sollte beim Einfügen der Zeilen zur Aktivierung von DEBUG, dass zu dieser AJAX Fehlermeldung bei den Erweiterungen geführt haben? Du merkst bestimmt, dass ich daran zweifle und nach wie vor verunsichert bin.

Ich habe gegoogelt nach dieser Fehlermeldung und habe sie nur in Verbindung mit dem PORTAL gefunden. Die Beiträge habe ich gelesen, leider wurde nie erwähnt was diese Fehlermeldung verursacht hat.

Gerne würde ich dem Fehler auf die Spur kommen, denn nochmal kann ich mir einen Dienstleister nicht leisten. Ich weiß das die Preise in Deutschland hoch sind, aber das war dass erste mal in über 10 Jahren phpBB dass mich eine Rechnung vom Hocker gehauen hat und ich bin wirklich nicht geizig.

Wenn ich jetzt sicher wäre, dass dies wirklich den Fehler auslöste, dann wäre ich beruhigt - ich bin aber nicht sicher. Und wenn Du (ich) in der Not Hilfe von Leuten die Du (ich) zu kennen scheinst brauchst, dann sagen die Dir .... ach im Moment habe ich keine Zeit.

Benutzeravatar
Kirk
Administrator
Offline
Beiträge: 1124
Registriert: Di 15. Apr 2014, 10:54
Wohnort: Erde
Kontaktdaten:
Jan 2020 22 19:04

Re: Problem beim aktivieren von Erweiterungen (AJAX-Fehler)

Beitrag von Kirk


Ich werde am Wochenende mal testen wenn man in diese Datei es verkehrt eingibt, dieser Fehler erscheint.
Gruß Udo

Benutzeravatar
Wolken
Offline
Beiträge: 36
Registriert: Sa 18. Apr 2015, 03:20
Kontaktdaten:
Jan 2020 23 16:02

Re: Problem beim aktivieren von Erweiterungen (AJAX-Fehler)

Beitrag von Wolken


Danke @Kirk für die spontane Hilfestellung. Findet man nicht mehr oft ;-)

Antworten

Wer ist online?


Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast