Voraussetzungen ... oder höher

Allgemeine Fragen rund um phpBB 3.2.x sowie 3.3.x
Benutzeravatar
Tina
Offline
Beiträge: 73
Registriert: Mo 3. Dez 2018, 23:40
Wohnort: Niedersachsen
Kontaktdaten:
Feb 2020 10 18:00

Voraussetzungen ... oder höher

Beitrag von Tina


huhu,
Voraussetzungen: phpBB 3.2.0 oder höher
nicht schmunzeln :mrgreen: aber darf ich mal fragen was genau damit gemeint ist ?

dieses wird ja oft bei erweiterungen bei geschrieben,
ich gehe mal davon aus das die erweiterung dann nur ab der phpbb version 3.2.0 funktioniert, so weit ist klar,
aber auch schon mit sicherheit im 3.3.0, oder was hat das oder höher zu bedeuten ?
lieben gruß tina
Bild

Benutzeravatar
Kirk
Administrator
Offline
Beiträge: 1022
Registriert: Di 15. Apr 2014, 10:54
Wohnort: Erde
Kontaktdaten:
Feb 2020 10 18:41

Re: Voraussetzungen ... oder höher

Beitrag von Kirk


Hallo
Ob eine Erweiterung unter phpBB 3.3.0 funktioniert lästt sich pauschal nicht beantworten, es kommt auf die jeweilige Extension an.
Gruß Udo

Benutzeravatar
Tina
Offline
Beiträge: 73
Registriert: Mo 3. Dez 2018, 23:40
Wohnort: Niedersachsen
Kontaktdaten:
Feb 2020 10 19:01

Re: Voraussetzungen ... oder höher

Beitrag von Tina


sorry, das verstehe ich nicht so ganz !

was hat dann die aussage -> Voraussetzungen: phpBB 3.2.0 oder höher zu sagen ?
das ist doch verwirrend :roll:
lieben gruß tina
Bild

Benutzeravatar
Kirk
Administrator
Offline
Beiträge: 1022
Registriert: Di 15. Apr 2014, 10:54
Wohnort: Erde
Kontaktdaten:
Feb 2020 10 19:36

Re: Voraussetzungen ... oder höher

Beitrag von Kirk


Mit jeder neuen phpBB Version kommen auch neue Events hinzu, wenn bei einer EXT "Voraussetzungen: phpBB 3.2.0 oder höher" steht, bedeutet dies das diese EXT Events benutzt die in 3.2.0 vorhanden sind.
Benutzt ein EXT Autor ein Event das erst z.b. ab phpBB 3.2.4 hinzugefügt worden ist, dann müsste die Voraussetzung: phpBB 3.2.4 oder höher sein. Das bedeutet das diese Extension innerhalb von 3.2.x funktioniert aber erst ab 3.2.4.
Ob diese auch unter 3.3.0 funktioniert, kommt auf die Erweiterung an.
Gruß Udo

Benutzeravatar
Tina
Offline
Beiträge: 73
Registriert: Mo 3. Dez 2018, 23:40
Wohnort: Niedersachsen
Kontaktdaten:
Feb 2020 12 15:36

Re: Voraussetzungen ... oder höher

Beitrag von Tina


ah ok, ich denke jetzt habe ich es verstanden.

dann ist also das My Quick Links Voraussetzungen: phpBB 3.2.0 oder neuer
innerhalb der phpbb 3.2.x nutzbar aber erst ab 3.2.0 und es garantiert nicht das es unter 3.3.0 funktioniert.

also erst wenn da steht: Voraussetzungen phpBB 3.3.x oder neuer/ höher garantiert mir das es in der phpbb 3.3.0 getestet wurde und funktionieren sollte.
lieben gruß tina
Bild

Benutzeravatar
Kirk
Administrator
Offline
Beiträge: 1022
Registriert: Di 15. Apr 2014, 10:54
Wohnort: Erde
Kontaktdaten:
Feb 2020 12 18:34

Re: Voraussetzungen ... oder höher

Beitrag von Kirk


Wenn bei einer Extension steht "Voraussetzungen: phpBB 3.2.0 oder neuer" kann diese dennoch unter 3.3 funktionieren. Es kommt auf die jeweilige EXT an.
Gruß Udo

Jonson
Offline
Beiträge: 34
Registriert: Mo 22. Aug 2016, 18:26
Feb 2020 12 19:38

Re: Voraussetzungen ... oder höher

Beitrag von Jonson


@Tina
Ich habe in meinem Forum (phpBB 3.3.0) die Erweiterung Signature fade in aktiv, obwohl es heißt "Voraussetzungen: phpBB 3.1.6 oder neuer" funktioniert es ohne Probleme.

Benutzeravatar
Tina
Offline
Beiträge: 73
Registriert: Mo 3. Dez 2018, 23:40
Wohnort: Niedersachsen
Kontaktdaten:
Feb 2020 20 14:24

Re: Voraussetzungen ... oder höher

Beitrag von Tina


hm, schon etwas verwirrend für einen neuling in sachen phpbb mit den aussagen die bei einer ext stehen !
also könnte ich (mal so gesehen) ja immer bei einer ext "als entwickler" einfach bei schreiben oder höher/ neuer ohne es getestet zu haben :(
[es sollte nur ein beispiel sein und keine behauptung das es einer macht]

na ja ich sehe das jetzt so das da einen wohl nichts anderes über bleibt als die ext einfach zu testen, egal was da steht :roll:
im acp wird es dir ja dann schon rot oder grün angezeigt,
so wie bei mir mit einer sozial media ext, voraussetzung 3.2.8 oder höher, läuft aber leider nicht unter 3.3.0
was ich sehr schade finde :cry:

vielen dank an euch für die infos
lieben gruß tina
Bild

Benutzeravatar
Kirk
Administrator
Offline
Beiträge: 1022
Registriert: Di 15. Apr 2014, 10:54
Wohnort: Erde
Kontaktdaten:
Feb 2020 20 16:59

Re: Voraussetzungen ... oder höher

Beitrag von Kirk


Was soll daran verwirrend sein?
Kirk hat geschrieben:
Mi 12. Feb 2020, 18:34
Wenn bei einer Extension steht "Voraussetzungen: phpBB 3.2.0 oder neuer" kann diese dennoch unter 3.3 funktionieren. Es kommt auf die jeweilige EXT an.
Gruß Udo

Benutzeravatar
Tina
Offline
Beiträge: 73
Registriert: Mo 3. Dez 2018, 23:40
Wohnort: Niedersachsen
Kontaktdaten:
Feb 2020 26 14:37

Re: Voraussetzungen ... oder höher

Beitrag von Tina


ja ok, "kann" ...

was ich meine das bei jeder extension beisteht oder neuer/ höher ...
und es dann doch nicht funktioniert wenn es man es drei vier mal probiert hat :(
da fragt sich doch dann der leihe, so wie ich es bin, was hast du falsch gemacht, da steht doch oder höher/neuer :roll:

und das finde ich verwirrend das es überall beisteht und es dann doch nicht geht, so meine ich das ;)
lieben gruß tina
Bild

Antworten

Wer ist online?


Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast